带标签的问题 'dpkg'

6
答案

如何从包中获取已安装文件的列表?

当我使用软件包管理器在Ubuntu上安装应用程序时,我想知道在哪里可以找到已安装的应用程序。 我安装了RabbitMQ并运行 locate rabbitmq ,这给了我以下结果: /home/anupamg/.m2/repository/com/rabbitmq /home/anupamg/.m2/repository/com/rabbitmq/amqp-client /home/anupamg/.m2/repository/com/rabbitmq/amqp-client/1.7...
29.03.2011 - 11:57
3
答案

dpkg和aptitude / apt-get有什么区别?

通过 dpkg -i packageA.deb 安装软件时,是否会自动下载并安装 packageA 所需的依赖项?这与使用 apt-get 或 aptitude ?有什么不同     
17.06.2013 - 09:08
7
答案

如何在从.deb安装软件时自动获取缺少的依赖项? [重复]

    这个问题已经有了答案:                  如何让'dpkg -i'为我安装依赖项?                                      10个答案                                我正在尝试在我的Ubuntu盒子(11.04)上安装 MySQL Workbench 。该网站有一个Ubuntu .deb可供下载(10.10和10.04,所以我选择10.10)。 然而, sudo dp...
22.08.2011 - 13:34
10
答案

如何让'dpkg -i'为我安装依赖项?

说,我有 foo-1.2.3.deb ,这取决于 perl 和 python ,但是,运行命令: dpkg -i ./foo-1.2.3.deb 不会安装这些依赖项。所以我必须手动 apt-get install perl python 。 如何让 dpkg -i 自动为我安装这些依赖项?     
04.05.2011 - 15:11
4
答案

'ii''rc'这样的各种dpkg标志是什么意思?

我经常需要检查安装了哪些软件包,并使用以下命令: dpkg -l | grep foo ,它提供以下输出 Desired=Unknown/Install/Remove/Purge/Hold | Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad) ||/ Nam...
25.12.2010 - 10:02
5
答案

如何通过dpkg找到已安装软件包的版本号?

我使用 dpkg -l 命令找出我安装的软件包的版本。例如: dpkg -l network-manager 返回包裹上的信息: Desired=Unknown/Install/Remove/Purge/Hold | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend |/ Err?=(none)/Reinst-required (Status,Err: uppercase...
30.11.2010 - 07:20
4
答案

dpkg错误:“试图覆盖文件,这也是......”

例如: $ sudo apt-get install curl Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: bsh : Depends:...
15.08.2012 - 14:31
4
答案

使用64位系统安装Teamviewer,但是我收到了依赖性错误

我正在尝试安装Teamviewer,但我收到了依赖性错误。我试图安装所需的软件包,但没有运气。 我收到了这个错误: Unpacking teamviewer (from teamviewer_linux_x64.deb) ... dpkg: dependency problems prevent configuration of teamviewer: teamviewer depends on lib32asound2; however: Package lib32asou...
21.10.2013 - 11:13
10
答案

是否可以从URL安装.deb?

有没有办法从URL 使用shell 直接安装deb包? 像这样的东西 dpkg -i http://domain.com/path/to/package.deb (我知道我可以使用wget然后使用dpkg,我只是想知道是否有某些功能已经存在)     
05.07.2011 - 12:28
2
答案

无法安装'openjdk-9-jdk',因为它试图覆盖'openjdk-9-jdk-headless'中包含的文件[复制]

我正在运行Ubuntu 16.04 Xenial桌面,64位,并且想要安装 openjdk-9-jdk (Java 9开发工具包)。 universe 存储库中提供的版本为 9~b114-0ubuntu1 。 运行安装命令成功安装依赖项(见下文,包括包 openjdk-9-jdk-headless ),但由于所述依赖项提供的文件也存在于有问题的软件包中,因此无法安装所请求的软件包: dpkg: error processing archive /var/cache/apt/a...
08.05.2016 - 21:34